Tips & tricks for installing and running IBM products

Failed Metrics update when Connections 4.0 is installed without Cognos

Tom Bosmans  5 June 2013 13:27:38
Recently, I was in 2 projects where we installed Connections 4.0 initially without Cognos.  1 installation was on Windows, the other one on Linux.

In 1 of the 2, we added Cognos later on - on it's own system, but that's not really relevant here.

We used silent installation methods to install fixpack CR2, and later CR3, and didn't immediately notice that the Metrics application failed to update.
So I looked into that.

It turned out that although the Metrics application installed succesfully, the update installer can't "see" it.  In the metricsInstall.log in the {Connections}/logs directory, an error occurs at action-update-server-info-cognos.
The end result is "Build Successful", but there's obviously some information missing.

Solution


We saw that for every component, there was a file in the in {Connections}/version directory , so for example, for Files :
- files.component
- files.product

These files do not exist for Metrics.

So what we did is :
- copy the files.component file, rename it metrics.component
- copy the files.product file, rename it metrics.product
- open each file and find/replace all occurences of "files" with "metrics"
- open each file and find/replace all occurences of "Files" with "Metrics"

Restart the Update wizard or the Silent update command, and you can now update the Metrics application.

Update


A colleague alerts me to a solution that prevents the issue from occuring in the first place.  When using the Silent install method (which I recommend :-) ), you need to add

user.metrics.cognos.node={your metrics server node}
user.metrics.cognos.server={your metrics server name}

This installs metrics correctly.  (Thanks Kedar).
Comments
No Comments Found